Статус
В этой теме нельзя размещать новые ответы.

Optima

Профи в Сат-ТВ
0
уровень 
Награды
4
Vitaliy_S,
Всё таки сделайте пожалуйста изменения в start.sh что я просил.

Нельзя его вообще выпускать в мир просто так. Его надо за NAT тупо садить, а если нужен доступ к нему из мира, то организовывать сначала VPN к себе в сеть. Иначе телнет все равно сломают, что с паролем что без, промежуточная точка для атаки народу часто нужна
Это всё хорошо конечно, может тогда скажете тогда, как на этом моде поменять дефолтный пароль :kathrein ,,? когда как passwd команда не распознаётся на этом имидже в телнете.
 

sathacko

Профи в Сат-ТВ
0
уровень 
Награды
1
вопрос знатокам: если в моем имидже (ааф2.0д витграф мод) тупо заменить файл pvrmain через фтп на файл от виталия , то будет ли работать мой имидж и не причинит ли это вреда????
 

Vitaliy_S

Профи в Сат-ТВ
0
уровень 
Награды
2
вопрос знатокам: если в моем имидже (ааф2.0д витграф мод) тупо заменить файл pvrmain через фтп на файл от виталия
не выйдет, cramfs монтируется read only, на BA можешь попробовать, только смысл такой огород городить ? :)
 

Filin-2008

Профи в Сат-ТВ
0
уровень 
Парни такая проблема...
запускаю рес, не кажет ш***. Грохаю mgcamd с консоли, потом стартую с консоли mgcamd и всё кажет.
Куда копать?
Такое проявляется на 2-х аппаратах.
p.s. Сейчас снял логи... mgcamd запущен но не работает. Если стартануть то начинает работать.
 
Последнее редактирование:

Vitaliy_S

Профи в Сат-ТВ
0
уровень 
Награды
2

allllex

Модератор
Команда форума
0
уровень 
Награды
1
Сейчас снял логи... mgcamd запущен но не работает.
В данном случае надо не логи смотреть, а сначала что он говорит, когда ты его грохаешь.
Грохаю mgcamd с консоли
А что говорит, когда грохаешь? Может ты только думаешь, что грохаешь.
Если вот это: no process killed, то он не был запущен.
И что он говорит, когда ты его запускаешь. Это и будет лог запуска.
С этими модами действительно что то не то. На некоторых модах и боксах эму заводится с пол - оборота, а на некоторых перестает видеть конфигурационную папку. Наверное не моды виноваты, а то, что было до этого на внутренней флешке. При установке классического имиджа очищается и переписывается только 6 секторов, а их на флешках 10. Остальные используются для энигмы2. (кроме 1 загрузчика) И после установки классического имиджа они не стираются. Все стереть можно только через гипертерминал. Надо просто переустановить эмулятор, скопировав его же туда же, где он лежит и проверить права 755. После этого все начинает работать.
Я правда копировал не тот, который уже загружен, а копию, которая есть на компе.
 
Последнее редактирование:

betina

Профи в Сат-ТВ
0
уровень 
Парни такая проблема...
запускаю рес, не кажет ш***. Грохаю mgcamd с консоли, потом стартую с консоли mgcamd и всё кажет.
Куда копать?
Такое проявляется на 2-х аппаратах.
p.s. Сейчас снял логи... mgcamd запущен но не работает. Если стартануть то начинает работать.
Аналогичная ситуация, переустановка mgcamd, ни чего не дала пока вернулся обратно на рудбокс 1.05, если сравнивать эти имеджи, то время загрузки немного быстрее.
 

Vitaliy_S

Профи в Сат-ТВ
0
уровень 
Награды
2
Filin-2008, betina, прошиваете мод после прошивки 6 файлами офф. 1.06 или на то что было до этого ?

Добавлено через 6 минут
Надо просто переустановить эмулятор, скопировав его же туда же, где он лежит и проверить права 755. После этого все начинает работать.
это не выход из положения, если эмулятор испорчен или не запускается, значит прошивка криво легла и просто переписав эмулятор нет гарантии, что все остальное не повреждено и будет нормально работать.
 
Последнее редактирование:

allllex

Модератор
Команда форума
0
уровень 
Награды
1
mgcamd запущен но не работает.
Ну неужто трудно подвесить этот лог, "запущен но не работает" убрав свои данные шары.
 

Def461

Новичок
0
уровень 
Странно в моем случае повела лайт-прошивка.
Умудрися "убить" оба имеющихся тюнера. Не получается залить её до рабочего состояния.
Архив перекачивал 3 раза, заливал 1.05 официальную, заливал 1.06 официальную в любых последовательностях.
Лайтовая виснет на надписи Kahrein UFS-910. Далее шьем только через сом-порт :(
 

Silantiy

Любитель Сат-ТВ
0
уровень 
Только что прошился. В key забросил свои настройки *ары. Настройки каналов через SatChannelListEditor 3.6.0.0 и все чудесно заработало. Запущен и не работает - через telnet проверте сеть.
P.S. Прежде залил офф 1.06.
 

Vitaliy_S

Профи в Сат-ТВ
0
уровень 
Награды
2
Умудрися "убить" оба имеющихся тюнера. Не получается залить её до рабочего состояния.
ума не приложу как можно было так изловчиться, чтобы убить катю, даже две....
Архив перекачивал 3 раза, заливал 1.05 официальную, заливал 1.06 официальную в любых последовательностях.
а вот слова "в любых последовательностях" как-то настораживают, нужно оф. 1.06, потом мой мод.
 
Последнее редактирование:

bigroma

Профи в Сат-ТВ
0
уровень 
Награды
1
Не все крутые как ты.

Да причем здесь крутой, просто смотри, насколько я помню скрипт, идет echo на /dev/vfd "MGcamd started", причем насколько я помню, код выхода не проверяется, так что надпись будет выведена в независимости от того выпал он или работает, если ошибаюсь поправьте.

Кстати если бы вместо пустых криков "не работает", к каждому вопросу добавлялся результат команд
ps -A
ifconfig
route
cat /etc/resolv.conf
ну и возможно ping чего-то типа ya.ru

то и помогать людям было бы намного проще.

Кстати эти разговоры типа ну это же линукс это так сложно просто пугают людей сделать элементарные вещи.
15 лет назад точно также пугали самим фактом существования компа :)
 

allllex

Модератор
Команда форума
0
уровень 
Награды
1
это не выход из положения
В данном случае это выход. Потому что если с первого раза установил и не запускается, переустанавливай имидж сколько хочешь. Результат будет отрицательный. Пока не поправишь эмулятор вручную на уже установленном имидже.
А эта установка с внешней флеши рекомендована производителем и ничего лучше не придумаешь.
Можешь попробовать для флеши закатать имидж в .kim и устанавливать через КСС.
Если бы был единичный случай незапуска, то это криво лег имидж. А это уже система, и криво ложатся во всех случаях только эмуляторы. Не странно ли это? На всех сайтах никогда не пакуют эмулятор и конфиги вместе с имиджем. Всегда эмулятры докачиваются на уже установленный имидж. Причем в большинстве случаев конфиги качаются отдельно. Или с сайта, или атоматом распаковывая подготовленный эмулятор из .tmp. Наверное не просто так это делают. На любом сайте, кроме нашего нет имиджа с встроенными эмуляторами.

Надо найти причину. У меня например до установки твоего имиджа, на ВА стояли три энигмы2 и 3 простых. У меня эмулятор имиджа от KVL не пошел. Переустанавливал раз 5. Переустановил эмулятор и все пошло. А вот после этого, когда устанавливал сверху твой, завелся с пол-оборота.

причем насколько я помню, код выхода не проверяется, так что надпись будет выведена в независимости от того выпал он или работает, если ошибаюсь поправьте
Сначала запускается эмулятор и только потом эта надпись
Код:
if [ $emu = "mgcamd" ]; then
  /data/www/cgi-bin/emustarter.sh mgcamd /data/keys/mg_cfg
fi
.......................
if [ $emu != "" ]; then
  /data/vfdctl -c "${emu} gestartet"
fi

Надо стараться никуда не лезть а по информации с терминала просто знать, что эму запустился и если нет шары не лезть куда то через комп, а через меню пультом все поправить в тюнере. Комп, это не придаток бокса, без которого нельзя обойтись. Хотя у нас это не получается.
 
Последнее редактирование:

Vitaliy_S

Профи в Сат-ТВ
0
уровень 
Награды
2
Да причем здесь крутой, просто смотри, насколько я помню скрипт, идет echo на /dev/vfd "MGcamd started", причем насколько я помню, код выхода не проверяется, так что надпись будет выведена в независимости от того выпал он или работает, если ошибаюсь поправьте.
разумеется, если делать вывод сообщения об успешности старта эмулятора, то делать его нужно на основании появления mgcamd в процессах, простой вывод без проверки конечно ерунда.
 

bigroma

Профи в Сат-ТВ
0
уровень 
Награды
1
то делать его нужно на основании появления mgcamd в процессах

Причем тогда с какой-то задержкой, потому как запуск, чтение конфигов, проверка серверов, быстро конечно, но какое то, да время, а замедлять запуск тоже не хочется.

Может уже лучше подождать OSD, и в нем уже проверять, запущен ли mgcamd.
А то сейчас "парой мелких фич" шустренький лайт превратить в монстра можно :)
 

allllex

Модератор
Команда форума
0
уровень 
Награды
1
А то сейчас "парой мелких фич" шустренький лайт превратить в монстра можно
В конце концов это случится, хотите вы или нет. Каждому будет что то надо. Так было со всеми имиджами с OSD. Вспомните конечного монстра от AAF с 10 языками OSD и кривым русским. Люди, которые это поняли, посто остались на Рудбоксе до сих пор.
Но с другой стороны имидж должен развиваться, это престиж автора.
Просто надо выкладывать больше вариантов а юзер сам остановится, когда сочтет нужным.
 

bigroma

Профи в Сат-ТВ
0
уровень 
Награды
1
Да понятно, "плавали, знаем", просто есть большое желание получить приятно едущий автомобиль, до того как начнется украшение хромом на радость цыганскому табору.
 

Vitaliy_S

Профи в Сат-ТВ
0
уровень 
Награды
2
А то сейчас "парой мелких фич" шустренький лайт превратить в монстра можно
тоже верно :)
наверное все таки займусь OSD, а лайт все кому нужно настроили и все работает, да он и не нуждается в настройке.
 
Последнее редактирование:

mihailp

Профи в Сат-ТВ
0
уровень 
Награды
2
Незнаю как люди умудрились все настроить но шара как не работала так и не работает(ни заливка оф. имиджа, ни замена эмулятора, ни танцы с бубном не помагают)
 
Статус
В этой теме нельзя размещать новые ответы.
Сверху